Macbook pro 13" Touch Bar 2018 A1989 the logic board sometimes turn on but sometimes does not

Admin

Repair Tv & Laptop
Support

Reputation:

PP3V3_G3H (C7670 pin 1): 3.35V
PPBUS_G3H (C3500 pin 1) :12.63V
When you power on the motherboard without keyboard does those voltage dropped .
 

Admin

Repair Tv & Laptop
Support

Reputation:

PP3V3_G3H (C7670 pin 1): 3.38V
PPBUS_G3H (C3500 pin 1) :12.63V

but on PP5V_G3S (C7607 pin 1): 0.01

All is connected without the keyboard, and I lose the 5V before I push the power button.
put your keyboard back than try to do a reset for SMC like that :
  1. On your built-in keyboard, press and hold all of the following keys. Your Mac might turn on.
    • Control
      macos-catalina-sidecar-sidebar-control-icon.png
      on the left side of your keyboard
    • Option (Alt)
      macos-catalina-sidecar-sidebar-option-icon.png
      on the left side of your keyboard
    • Shift
      macos-catalina-sidecar-sidebar-shift-icon.png
      on the right side of your keyboard
  2. Keep holding all three keys for 7 seconds, then press and hold the power button as well. If your Mac is on, it will turn off as you hold the keys.
2020-macbook-air-keyboard-diagram-smc.png
 

ioan.onutu

Member (✔)

Reputation :

put your keyboard back than try to do a reset for SMC like that :
  1. On your built-in keyboard, press and hold all of the following keys. Your Mac might turn on.
    • Control
      macos-catalina-sidecar-sidebar-control-icon.png
      on the left side of your keyboard
    • Option (Alt)
      macos-catalina-sidecar-sidebar-option-icon.png
      on the left side of your keyboard
    • Shift
      macos-catalina-sidecar-sidebar-shift-icon.png
      on the right side of your keyboard
  2. Keep holding all three keys for 7 seconds, then press and hold the power button as well. If your Mac is on, it will turn off as you hold the keys.
View attachment 38592
I tried exactly as you told me, the macbook was turned on, but something strange was happened, I attached some videos with exactly situation which happened.

I could enter in the recovery assistant, but at some point the macbook was turned off, and I tried to do reset the SMC again, but the macbook remains off...

How can you explain that?
Actually is beyond me....
 

Attachments

ioan.onutu

Member (✔)

Reputation :

I tried exactly as you told me, the macbook was turned on, but something strange was happened, I attached some videos with exactly situation which happened.

I could enter in the recovery assistant, but at some point the macbook was turned off, and I tried to do reset the SMC again, but the macbook remains off...

How can you explain that?
Actually is beyond me....
put your keyboard back than try to do a reset for SMC like that :
  1. On your built-in keyboard, press and hold all of the following keys. Your Mac might turn on.
    • Control
      macos-catalina-sidecar-sidebar-control-icon.png
      on the left side of your keyboard
    • Option (Alt)
      macos-catalina-sidecar-sidebar-option-icon.png
      on the left side of your keyboard
    • Shift
      macos-catalina-sidecar-sidebar-shift-icon.png
      on the right side of your keyboard
  2. Keep holding all three keys for 7 seconds, then press and hold the power button as well. If your Mac is on, it will turn off as you hold the keys.
View attachment 38592
Hello again,

I tried to perform again all the steps that you told me and today I really succeed to open the macbook, but I noticed something, when the macbook waited for me to introduce the password, the fans was not spin at all, and the heat pipe was very very hot. Another thing I saw was when I tried to disconnect the keyboard connector and it was half disconnected the only left fan starts to spin to a full maximum capacity. You can see more specific and in detail in the videos attached.

So, I am asking you, do you thing the problem is on the 5V fan power supply line?

Your help will be appreciate it.
Thank you in advance.
 

Attachments

Admin

Repair Tv & Laptop
Support

Reputation:

Hello again,

I tried to perform again all the steps that you told me and today I really succeed to open the macbook, but I noticed something, when the macbook waited for me to introduce the password, the fans was not spin at all, and the heat pipe was very very hot. Another thing I saw was when I tried to disconnect the keyboard connector and it was half disconnected the only left fan starts to spin to a full maximum capacity. You can see more specific and in detail in the videos attached.

So, I am asking you, do you thing the problem is on the 5V fan power supply line?

Your help will be appreciate it.
Thank you in advance.
spin goes a full maximum mean that some sensor devices not connected well .
 

Admin

Repair Tv & Laptop
Support

Reputation:

ok, so that explain why the starts to spin in a full maximum load, but also why is not spinning at all when the macbook was turned on?
There is some Software tool that can do an auto diagnostic to check for a sensors problem, fans, and other things but i don't remember the name of this software .
 

ioan.onutu

Member (✔)

Reputation :

There is some Software tool that can do an auto diagnostic to check for a sensors problem, fans, and other things but i don't remember the name of this software .
Anyway, the software will not help me because I am in the same situation, missing 5V and the macbook was not turn on anymore...

It is a loop, something happened and cut the 5V and I really don't know what.
What I noticed the ENABLE signals from U7800 are missing all of them, I think the IC is the problem...
 

Admin

Repair Tv & Laptop
Support

Reputation:

Anyway, the software will not help me because I am in the same situation, missing 5V and the macbook was not turn on anymore...

It is a loop, something happened and cut the 5V and I really don't know what.
What I noticed the ENABLE signals from U7800 are missing all of them, I think the IC is the problem...
You can try to change it but it's not easy to do it.
 

ioan.onutu

Member (✔)

Reputation :

Hello again,

I have one more question about this topic, and after that I will not stress you again.
I noticed that when the 5V is cut U7650 lose the ENABLE signals, I have 0V on P5V_P3V3G3H_LDO_EN, P5VG3S_EN_R and P3V3G3H_EN_R but there is very important thing, on the board R7671 is not placed, is it normal? if I don't have that resistor placed why I have 3.38 measured on C7666??? that means the 3.3V is enabled, but how?

Additional:
I measured the PGOOD signals also:
P5VG3S_PGOOD: R7670 pin 2: 0V
P3V3MAIN_PGOOD: R7690 pin 2: 0V

Very strange things get happened on my board...
Thank you in advance.
 

Admin

Repair Tv & Laptop
Support

Reputation:

When you power on your laptop you will get PMU_PVDDMAIN_EN mean P5V_P3V3G3H_LDO_EN
And
P5VG3S_EN mean P5VG3S_EN_R
For R7671 and C7640 if you see the schematic you will see "NO STUFF" is been writed under those components.
NO STUFF mean not been installed.
Check those pin 21, pin 12 ,pin 4 on U7650 .
 

ioan.onutu

Member (✔)

Reputation :

When you power on your laptop you will get PMU_PVDDMAIN_EN mean P5V_P3V3G3H_LDO_EN
And
P5VG3S_EN mean P5VG3S_EN_R
For R7671 and C7640 if you see the schematic you will see "NO STUFF" is been writed under those components.
NO STUFF mean not been installed.
Check those pin 21, pin 12 ,pin 4 on U7650 .
pin 12: 0V
pin 21: 0V
pin 4: 0V

Very strange thing on C7666 I measured 3.34 V, in that case on pin 12 I have 0V, the PP3V3_G3H signal should not be active. I read the datasheet, in that case there are a 3V3 LDO active, but that means on pin 22 (P5VP3V3_VREG3).

Additionally I measured the next pins:
pin 22: 9.22 (IT SHOULD BE 3.3V)
pin 29: 0V
pin 13: 0V

I think that IC is broken internally, but how can be 100% sure? Can I measure that?

Thank you in advance.
 
Top Bottom